Introductory Exercise:
The Informatics Unix Environment...
Roger Burroughes
<roger@inf.ed.ac.uk>

This practical is an introduction to the computing systems (referred to as "DICE") in
Informatics, and is a familiarisation exercise. Working through this practical in conjunction with
the introductory notes1 should help you:
•
•
•
•
•

Login into the DICE environment
Familiarise yourself with the Gnome environment
How to change your password
How to print
How to use the Unix command line, and execute simple commands

This practical is optional — there is no need to actually do the exercises if you feel confident
enough with the material described. However, it is important that you are (or quickly become)
familiar with basic Unix (Linux) commands and file structure  familiarity will be assumed by the
taught courses.
Note that other teaching information is available from:
web.inf.ed.ac.uk/infweb/student-services

A reminder that you may want to refer to the accompanying
introductory notes to help you with some parts of
these exercises.

1 Some commands may not be fully described in this practical  refer to the introductory notes for more
detail

Conventions
Linux is an implementation of the Unix operating system, and the two names can (for the
purposes of this document) be used interchangeably.
When examples of commands are shown in the text, they may appear with a full Unix
commandline prompt, or merely “%” — the latter may be interpreted as “whatever your Unix
prompt happens to be”, and should not be typed in when following any example.
Also, example commands may be enclosed in quotation marks  these should not be typed in
when entering the command.
If you see italicised strings such as <filename>, "<text here>", or anything similar, you
should replace everything (including the anglebrackets) with something more meaningful (it's
normally up to you to choose). Do not include quotation marks, anglebrackets, or any other special
characters unless specifically stated.
Some commands use special keystrokes, and involve either the “Control” or the
“ESCape”(possibly also known as the “Meta”) key. The Control key is often written as “Ctrl”, or “ ˆ”
(also called ’hat’ or ’caret’), or “C”. We will be using the ‘Ctrl’ convention, so Ctrlx should be read
as “while pressing and holding down the key marked ‘Control’, press and release the ‘x’ key”.
Likewise (usually in Emacs) ‘Meta’ commands are often written as ‘M’, and can use either a
special ‘Meta’ key (if your keyboard has one), or the ‘Escape’ (ESC) key. So Mx should be read as
“press (and release) the ‘Escape’ (ESC) key, and then press the ‘x’ key”.
If your keyboard has the special ‘Meta’ key, then interpret 'Mx' as “while pressing and
holding down the ‘Meta’ key, press and release the ‘x’ key”) 2
In the “Ctrl” and “M” sequences, the following letter may be given in upper or lower case
— always type it in lower case.

2 Note the difference between the use of the ‘Meta’ and ’Escape’ keys  the former is pressed down while you
press the other key, that latter is pressed down and released before the next key is pressed.

Logging on
First, make sure you have your DICE username and password (you should have received
details of these via email, with the subject line "Your Informatics password" 3) — if you haven’t got
your account details yet, check with the ISS (Informatics Student Services, in Room 1.B15 of Forrest
Hill) or go to the Support Desk (Room 3.D09). Note that your DICE (Informatics) account is not
the same as your central services account (for use in the library, etc), and they will use different
passwords.
Machines for student use are available in Forrest Hill:
•
•
•

Ground floor – G.A11 (Robotics lab)
First Floor – 1.B04, 1.B09, 1.B10, 1.B19, 1.B30 (Drill Hall), 1.B31 and 1.B32
Third Floor – 3.D01, 3.D02 (SDP lab)

The main labs are on the first floor  for a detailed list of all labs and their availability, see
the “Computing Labs” web page at:
http://www.inf.ed.ac.uk/admin/ITO/computinglabs.html
Once you have found a free machine, try logging in:
•

•

Type your username in the “Username:” box, remembering to type it in lower case, and
press <Return>
(At this point, you can select your preferred Window Manager from the dropdown menu in
the top righthand corner of the login screen. Unless you are familiar with Linux Window
managers, then we recommend that you use the default – GNOME).

(If the screen is blank, or the prompt does not appear, press the <Return> key on the keyboard (or
move the mouse) and the prompt should then appear.
Once you have entered your username (login, or account name) successfully, you should
supply your password:
•

Type your password in the “Password:” box.

Type this in exactly as given (as set by you following instructions in your Informatics DICE
account email). Make sure that upper case letters are typed in uppercase!
If you are sure that you have correctly typed in your username and password, but still can’t
log in, let one of the lab demonstrators know (make sure you have checked this a few times first,
and check that you haven’t turned capslock on unintentionally).

3 Note that "Informatics account/password" and "DICE account/password" refer to the same account &
password.

Gnome Desktop Environment
Once you have successfully logged in, the main desktop screen should appear, with an
Activities tab in the top lefthand corner and a few icons in the top righthand corner.
Open a terminal window by clicking the "Activities" tab and then clicking the ‘terminal’
icon – second bottom from the icons displayed on the lefthand side.
•

Browse the popup menus. Find and click on the “Show Applications” icon. At the bottom
of the screen you will see a toggle option “Frequent/All”.

To close windows that you may have open, you can:
•
•

use the “close” button in the top right corner (a small box with an “X” in it)
if the window has a “File” menu in the top lefthand corner, there may be a “Close”, “Quit”,
or “Exit” option under it.

If you are using a shell (terminal) window, you can use the close button, or “File ⇒ Close
Window” menu option, or type CtrlD (ˆD) at the prompt.

Adding an icon to the Activities bar
It’s important that you use the screen lock when you leave your desktop unattended (for a
short period of time only!).
Click on “Activities” and select “Show Applications”. Browse through the “All” option until you find
“Screen Lock”. Now rightclick on this icon and select “Add to favourites”. It will now appear in the
lefthand column of icons.

Exiting Gnome (Logging off)
Once you feel comfortable with moving around the desktop, you can end your session (“log
out”). Click on your name in the top right corner and you will see a logout option.

Changing your password (optional)
Note that if you've set up your own account details using the link sent to you via email, you
will already  hopefully  have set a memorable password. Consequently there is no need to reset
your password here  but feel free to change it again if you wish (otherwise you can skip this
section).
In order to change your password, you’ll need to login (if you’re not logged in already) using
your original password, and then use a shell (terminal) window to type the passwordchanging
command passwd (or use the "Change Password" option in “System ⇒ Preferences ⇒ About Me”.
•

Log back on to the machine and wait until Gnome has started up again.
(Assuming you’re not already logged in.)

•

Open a shell window, and move the cursor to it (and click if required) to give it focus.
(This makes it active — the current window — so that you can type in it.)

•

Use the passwd command — enter your old and new passwords when prompted, as in the
following example (and hit <Return> after each password entry):
% passwd
Changing password for user infteach:
Current password: <password typed here  but is not shown>
New password: <password typed here  but is not shown>
Retype new password: <password typed here  but is not shown>
passwd: all authentication tokens updated successfully
%

Remember that, when using the commandline method, you won’t see anything when you
type in your new password  the characters are not printed on the screen...
If you fail to choose a suitable password, you may see the following errors:
•
•
•

BAD PASSWORD: it is WAY too short
BAD PASSWORD: is too similar to the old one
BAD PASSWORD: it does not contain enough DIFFERENT characters
Alternatively, you may use the graphical version to change your password:

•

Choose “Change Password” from “System ⇒ Preferences ⇒ About Me”.

You should then be prompted for your “Current password”, which is your usual password, and then
for a new password, and then for confirmation of the new password. Or you can use the
“userpasswd” command on the command line:
% userpasswd
– which will bring up the same passwordchanging dialogue box as in the graphical version above.
In both the command line and graphical cases, you may cancel 4 at any point before completion.
•

Now log out of the computer, cross your fingers, and try logging back in again using

4 Using the “Cancel” button in the graphical method, or by pressing the “Ctrl”and“c”keys simultaneously in
the command line method.

your new password!
If this fails (using your new password), try again using your old password. If this fails, you’ll
need to get outside help to change it to something that works! (Remember to check both methods a
couple of times before you give up and get help!)

Webbrowsing (optional)
The default webbrowser is Firefox — try starting this (you should be able to do this from
the button on the control panel5, or using the "Firefox Web Browser" menu option under “Internet”
on the “Applications” menu6. It is better (for the moment) if you stick to using Firefox as your
browser, unless you are more familiar with the others that are available.
Browse the Edinburgh University pages, starting at the URL http://www.ed.ac.uk/. You
might also want to look at the Informatics Teaching pages at
http://www.inf.ed.ac.uk/studentservices/teachingorganisation.
Links to the Introductory notes on DICE and the handson tutorial can be found on the
following page:
https://computing.help.inf.ed.ac.uk/newtaughtstudents
If your homepage is not already set to the Informatics Student Home Page:
•

Enter the URL http://www.inf.ed.ac.uk/studentservices/studentservices (either via the
location bar, or the “File ⇒ Open Location” menu option — which will just highlight the
location bar).

•

Once the page is displayed, use the “Edit ⇒ Preferences ⇒ General” section to set the “Home
Page” by clicking the “Use Current Page” button.

— or use this method to set it to something else, if you feel that the Informatics Student Home Page
is not sufficiently interesting.
If you leave your browser opened on some computer that you are logged on to, you cannot open the
browser on any other machine.

5 The one with the fox and globe — holding the cursor over this button should show “Firefox Web Browser”.
6 You can also use the command“firefox” on the command line —but this will tieup your terminal window
until you quit.

Printing
In order to be able to print, you must select a default printer (see below), or specify one
explicitly with the printing command. To select a default printer, type the following magic
incantation:
echo "export PRINTER=printername" >> ˜/.benv
— where printername is the printer that you have identified as your default (usually in or near one
of the labs), and the funny "~" character at the start of "˜/.benv" is called a "tilde"7, and can
probably be found as the shift character on the hash ("#") key. (The tilde can be used as a shorthand
way of referring to your home directory).
One way of identifying various printers is to select "File ⇒ Print" with Firefox, which will
bring up a printer selection list. Identify a suitable printer, and take a note of the character string
below "Printer"  this is the printername. Don't forget to cancel the Firefox print request!
Note that only certain printers are accessible, and you should only choose printers that
start with "fh" (for Forrest Hill), followed by a Level number ("1"or "3"), plus room and then either
m0 or c0 (for mono vs colour) e.g. fh1b30m0 Each printer has a label attached to it to help with
identification.
Once a default printer is selected, you should run the above command again, but without
the “echo” command, without the quotes, and without the output redirection (that's without the
“>> ˜/.benv” bit):
export PRINTER=printername
This enables default printing in your current window — it would otherwise not be effective until
you logged in next time.
NEW FOR 2016!  Cloud printing! Follow the instructions displayed beside the printer in the Drill
Hall.

7 Pronounced with two syllables, "tillda"

Some Simple Unix Commands
To use Unix (Linux) commands, we need a "prompt" (Unix commandline). This is the
standard way of entering Unix commands. To experiment with this:
•

Open a shell window.

•

Type any random text at the shell prompt and then use the <Backspace> and <Delete>
keys on the keyboard to change the text.
See what happens if you press <Return> before you delete all the text.
If you type a command that the shell does not recognise, it should display a message similar

to:

bash: xyz: command not found
where “xyz” is whatever you typed (and what the computer didn’t understand).
(Remember to press <Return> after you have typed in your commands.)
If you type a long (or even not so long) command on the command line and get it wrong,
you don’t need to retype the whole thing when correcting it. You can take advantage of the history
mechanism, which stores the most recent of your commands in a list that you can select from. If
you type “history” at the prompt, you will see a list of your last commands — for example:
[corgarff]infteach: history
1 echo "export PRINTER=lw3" >> /home/infteach/.benv
2 cat /home/infteach/.benv
3 lpq
4 export PRINTER=lw3
5 firefox
6 bg
7 lpq
8 history
[corgarff]infteach:
You can then use the up and down arrow keys, or CtrlP (for “previous”) and CtrlN (for
“next”), to select the command you want8 (each command is displayed in turn on the current line).
When you see the line that you want, you can use the cursor and delete keys to edit or change the
line, and then just hit the <Return> key to execute the new command.

Files and Directories
To see what files you have in your current directory (which should still be your “home
directory”), you can use the “ls”9 command:
•
•

From a shell window, run the “ls” command (that's lowercase L S) — see what you get.
To check which directory you are in run “pwd” (which stands for print working directory)

8 The command appears on the current line — there is no interaction with the output from the “history”
command.
9 That’s the lowercase letters “L” and “S” — the first character is not digit “one”!

•

From the desktop, click on the “Home” icon and compare output with that of the “ls”
command.
You can also tell “ls” to look elsewhere by giving it an argument:

•

Use “ls /home/infteach” to examine the contents of the demo account <infteach>.

•

What is the shorthand way of referring to “the home directory of the infteach account”?
(You may need to check the introductory notes to find this out  although it was briefly
mentioned above.)

Copies of files can be made with the “cp” command (see introductory notes for more
details). You can either duplicate your own files, or take copies of files in other locations (provided
they are readable by you, of course — private files can’t be copied).
•

copy the file “/home/infteach/system/testfile1” to your home directory, calling
it “example1”.

If you have successfully copied the example file to your home directory, you should be able
to view it with a pager10:
•

type “less example1” at the prompt and see what is displayed.
— you should see something that starts like this:
John Barleycorn
===============
There was three Kings into the east,
...

•

move to the ‘infteach’ area as above (using the "cd" changedirectory command  but
not simply "cd"), then confirm that you’re in the right directory, list the files there, and then
move back to your home directory using the shortcut version of the command.
In the infteach directory, you should see a subdirectory called "Files".

•

using “cd”, “ls”, and “less”, try moving to this directory and see if you can view the
file contents.

Note that this will not be possible for all files: for example, those files which end in ‘.ps’ are
PostScript files11, and should not be viewed using less — they require a special viewer. If a file will
not view properly with “less”, you will see the warning:
“filename” may be a binary file. See it anyway?
— type “n” at this point to cancel the operation.

10 Use “q” to quit pager.
11 PostScript is a lowlevel page description language.

Disk usage and Quota
You can check your disk space quota with the “fs listquota” command (which can be
shortened to “fs lq”). This gives your maximum quota figure and your current usage (both in Kb).
For example:
infteach% fs listquota
Volume Name
Quota
user.infteach
1000000
infteach%

Used %Used Partition
19442
2%
61%

This shows that the user infteach has a maximum quota of 1Gb (the default quota for 1st and 2nd
year undergraduates is 4Gb and all other students is 10Gb) and has used approximately 19Mb,
which is two per cent of the user’s allocated quota (also shown is the percentage of space used on
the disk partition which contains the user’s home directory).
•

Check your quota and current usage, using the shortened version of the quota
command

•

Copy ~infteach/bigfile to your home directory, and check your quota again

•

Delete your copy of bigfile

Creating directories & moving files
Make sure that you’re in your home directory before running the following commands (use
the cd command). If you’re not in your home directory, you may not be able to create the
necessary files.
•

create a directory called “examples” using the mkdir command.

•

copy the file “example1”12 into the “examples” directory using the cp command.

•

rename the file “example1” (in your home directory) to “assessment” using mv.

•

move to the “examples” directory (by using the "cd" command) and check that you
have a file called “example1” in it (using "ls")

•

try moving to the “system” directory in the ‘infteach’ area (use "cd" to get there), and
copy the file “testfile2” back into your “examples” directory, and call it
“example2”. (Hint: use "ls" in your examples directory to make sure that you’ve been
successful.)

To delete files, you should use the "rm" command. Make sure you’re in your home directory,
and then:
•

delete the file “assessment”

To delete directories, use the "rmdir" command:

12 Which you should have created in your home directory earlier in this practical — if not, go back over these
notes and track it down.

•

try removing your new “examples” directory.

Does this work, or is there an error?13
•

remove any files remaining in your "examples" directory and then remove the
directory.

Command Line Completion
To complete long filenames, use the<Tab> key.
•

type: "less ˜infteach/av" <PRESS TAB>

The shell will magically fill in the rest of the filename for you — it will fill in as much as it
can, but if there is a choice, it will fill in the shared portion (those characters that are common to all
possible options) and wait for you to fill in the rest. You can type in some characters and press
<Tab> again to complete the filename, or pressing <Tab> twice will list all the alternatives.
•

type: "less ˜infteach/ch" <PRESS TAB THREE TIMES>

This shows that there are two files which begin with ‘ch’ — choose additional (unique)
letters to specify a particular file, and press <Tab> again.
You may wish to experiment further with these commands to make sure that you know
exactly how they work. If you are feeling brave, try reading the manual page for particular
commands — the manual pages are not very userfriendly, but they do give you a list of the syntax
of each command (how to use it, what arguments and flags it takes, and suchlike). To do this, use
the “man” command followed by the command name you want to look up (you can even use it on
itself):
% man man
If you have any further questions, ask your lab demonstrator, or complete the online help
form (http://www.inf.ed.ac.uk/systems/support/form).

13 You should see "rmdir: ‘examples’: Directory not empty."

Unix Files
This section will give you some practice in finding out information about files.
Unix Commands & Utilities
1. Look at the manual page for “ls”, or type the command “ls help”, and acquaint

yourself with all the various options and flags. Work out how to do listings in colour, and
without colour. Which is the default?
2. This next one may take a bit of working through — feel free to skip it if you’re short of time

The man page for ls refers to the info command. Using “info ls” (“q” to quit), see if
you can identify all the parts of the output of “ls o .bash_history” (assuming you are
in your home directory).
You’ll need to work out how to drive “info” first! For more info on info, see the “info” man
page — note that there’s more than one “info”, so you’ll need to specify which section of the
manual you want to look in (use “man 1 info”).
3. Identify the most recently modified file in your home directory

(Hint — check flags for “ls”).
4. How many characters does the poem file (~infteach/system/poem) have? (You may

find the "wc" utility useful here  check the man page, "man wc".)
5. Using the "file" command, examine the files in the ˜infteach/Files directory. Do you

agree with what "file" says? (There are some files that it doesn't get quite right.)

Special characters
1. The “*” (star, asterisk) character matches anything and everything (zero or more instances

of something).
How would you specify all filenames (and directories) which contain the string “test”?
(Test your answer using “ls ˜infteach/<your pattern here>”).
2. How would you repeat the "examine the files in the ˜infteach/Files directory" example

above using “*”?
3. The “?” character matches a single character only. How would you use it to match all files of

eight characters?
4. How would you use “*” and “?” to list filenames of at least four characters?

Chaining commands together14 with pipe
14 See "man bash" ("Pipelines" section, under "SHELL GRAMMAR")

There is a special character, the vertical bar "|"15 or "pipe", that allows you to pass the

output of one command to the input of another command by placing it between the two
commands:
% <command1> | <command2>
1. Roughly16 how many files and directories do you have in your home directory?17
2. How many files are in the “˜infteach” directory18 (at top level)?
3. There may be more files in “˜infteach” than will fit on one screen. How would you use a

pager (for example, “less”) to display only a screenful at a time?

Editing Text With Emacs
Note that the first Haskell practical should give you an excellent opportunity to practice your
Emacs skills. If, however, you would like to experiment a little more first, there is an Emacs tutorial
within Emacs itself:
1. Start Emacs from the command line (just type “emacs” at the Unix prompt and hit

“<Return>”)
or
Select “Emacs” from the “Applications ⇒ Accessories” menu.
2. Select “Emacs Tutorial” from the “Help” menu at the top of the Emacs window.
3. When you’ve finished, type “Ctrlx, Ctrls” to save it19, then “Ctrlx, Ctrlc” to quit.

Or (or in addition) you can try the local tutorial by taking a look at the Emacs tutorial
document, http://www.inf.ed.ac.uk/teaching/courses/inf1/system/practicals/emacstutorial.pdf.

15 The "|" character will probably be on the backslash (not the forwardslash) key
16 There may well be "hidden" files (those that start with a dot), that are not included here.
17 In this case, "your home directory" means just at top level, not including contents of subdirectories
18 If you use “ls o” you may need to use the “L” flag too, as “ls o” may show you that “infteach” is just a link
(shortcut) to another location. The “L” flag hides this confusing fact.
19 If you selected the “Emacs Tutorial” from the “Help” menu, the file will be saved as “TUTORIAL” in your
home directory.

